Recherche

FORUM AUTOUR ET HORS DU JEU DE ROLE » Customs

[Script] Com'back

Créé par Valion le 24 Février 2016 à 22:15

Visible par tout le monde
Nom du sujet
Visibilité du sujet 
Type de sujet
Poster
Valion Posté le 24 Février 2016 à 22:15 #1
Avatar
Faim de loup
Compte Premium
Voir mon EDC
♫ Musique d'ambiance. :3

Vous l'attendiez, vous en rêviez (ouais bon, peut-être pas), le voici...


Com'back, version 1.0!


Introduisant...des liens cliquables, et des images!
Et son propre topic sur le forum. Yeay.



Résumons l'intérêt de ce script, donc la description complète est accessible à l'adresse du lien plus haut (ou ici, si vous êtes feignant. Ou là.):

- Ajout d'un menu déroulant, dont le choix règle un en-tête pour votre message. Il permet principalement de définir si votre personnage fait un message audio, vidéo, écrit... Le choix par défaut est réglable.
- Ajout de boutons raccourcis pour intégrer des bouts de texte comme un accusé de réception, une notification de téléchargement...là aussi personnalisable.
- Pour les utilisateur du script uniquement, les liens deviennent cliquables. Il n'y a aucune mise en forme à réaliser (ce qui pénaliserait les non-utilisateurs). Il est cependant conseillé de mettre un lien seul sur une ligne. Il doit commencer par http:// ou www. .
- Les liens d'images se transforment en images, sur lesquelles vous pouvez cliquer pour les afficher dans un nouvel onglet. (Utilisateurs uniquement, les non-utilisateurs ne verront que le lien tel quel).


N'hésitez pas à poser vos questions, remarques, découvertes de bugs ici. smiley
Valion Posté le 25 Février 2016 à 23:37 #2
Avatar
Faim de loup
Compte Premium
Voir mon EDC
@Radium J'ai du rater un truc...? Si tu as une question/remarque/Etc, pose-là. smiley
Inconnu Posté le 26 Février 2016 à 00:29 #3
Les boutons a droite de la fentre de com apparaissent vides chez moi.

Sinon c'est super génial top.
Valion Posté le 26 Février 2016 à 00:56 #4
Avatar
Faim de loup
Compte Premium
Voir mon EDC
Est-ce que le jeu d'icônes bugue en général? (Dans les en-têtes aussi, je parle)
J'ai un autre ordinateur qui a beau être sous Win7, il ne sait pas afficher les caractères Unicode, donc ça peut venir de là. A mon avis, ça vient même de ça.
Ren Posté le 26 Février 2016 à 01:04 #5
Avatar
-
Compte Joueur
Voir mon EDC
Moi c'est sous Win10 que ça s'affiche pas les unicode, le pc est assez vieux par contre.

Edit: Ayé! smiley
Valion Posté le 26 Février 2016 à 01:06 #6
Avatar
Faim de loup
Compte Premium
Voir mon EDC
C'est pour ça que je conseille à tous ceux qui utilisent le script d'annoter leurs caractères Unicode, pour ceux qui ne peuvent pas les lire!

Il paraît que des solutions existent pour les afficher, mais j'ai eu beau reconfigurer la moitié de mon navigateur, installer vingt polices différentes et mettre à jour l'OS, ça a rien changé (pour un PC gaming, c'est un peu la loose). C'est un peu la loterie. :/
Inconnu Posté le 26 Février 2016 à 01:09 #7
merci ^^

Je ne comprend rien ou presque , mais en memorisant les boutons ca devrait aller.

En tout cas merci, ce script est putain de cool.
Valion Posté le 26 Février 2016 à 01:11 #8
Avatar
Faim de loup
Compte Premium
Voir mon EDC
C'est seulement les boutons qui buguent, pas le reste (genre tu vois bien les icônes dans les messages)?
Inconnu Posté le 26 Février 2016 à 01:11 #9
Oui, tout fonctionne, y'a juste les boutons qui s'affichent vides.
Valion Posté le 26 Février 2016 à 01:13 #10
Avatar
Faim de loup
Compte Premium
Voir mon EDC
Euuuuh...vraiment bizarre. Essaie de remplacer dans le script les caractères entre guillemets, ligne 25 à 30, par des lettres, pour voir si ça les affiche.
Ca te fait ça sur la fenêtre de nouveau message ET sur la fenêtre de fil de com'?
Et au passage, dis-moi si dans le script tu voyais bien les caractères en question.
Inconnu Posté le 26 Février 2016 à 01:18 #11
ouip ca affiche les chiffres maintenant ^^.
Valion Posté le 26 Février 2016 à 01:22 #12
Avatar
Faim de loup
Compte Premium
Voir mon EDC
Tu peux répondre à toutes les questions, stp? Ca m'aiderait pour t'aider. Ouais, dit comme ça, c'est...bizarre.
Inconnu Posté le 26 Février 2016 à 01:23 #13
Oui, sur les deux types de fenêtre.

je suis sous win 7.
Valion Posté le 26 Février 2016 à 01:24 #14
Avatar
Faim de loup
Compte Premium
Voir mon EDC
Et dans le code du script, tu voyais les caractères que tu as remplacé?
Ton navigateur, aussi, stp
Inconnu Posté le 26 Février 2016 à 01:25 #15
je voyais des petits symboles dans des carrés (totalement a chier en info, dsl ^^), et je suis sous chrome.
Valion Posté le 26 Février 2016 à 01:27 #16
Avatar
Faim de loup
Compte Premium
Voir mon EDC
Et en jeu, tu vois des petits carrés pareils (dans les messages)?
Inconnu Posté le 26 Février 2016 à 01:31 #17
nope, je vois ça:

【📎 Pièce jointe: ""】

【📨 Accusé de réception】

【📤 Envoi de données en cours: ""】

【🔃 Chargement en cours, veuillez patienter.】

【📄 Fichier: ""】
Valion Posté le 26 Février 2016 à 01:33 #18
Avatar
Faim de loup
Compte Premium
Voir mon EDC
Tu vois un trombone pour la pièce jointe ou un autre truc chelou?
(Parce que là tu as copié collé le texte et donc ça m'interprète bien les icones vu que je peux les lire, mais ça ne me permet pas de savoir si toi tu les lis ou non)
Inconnu Posté le 26 Février 2016 à 01:36 #19
nope je vois pas de trombone, juste ces encarts texte.
Valion Posté le 26 Février 2016 à 01:40 #20
Avatar
Faim de loup
Compte Premium
Voir mon EDC
Bon, désolé alors, mais tu as le même souci que moi, qui fait que tu ne peux pas lire les caractères Unicode. Essaie avec Firefox, des fois qu'un miracle se produise, mais j'y crois pas trop.
Je note quand même qu'on est deux à avoir des caractères Unicode qui ne marchent pas en étant sous Windows 7.

@Ren Pour toi c'est peut-être l'âge du PC, peut-être Win10, peut-être Chrome (qui d'après la littérature googlesque supporte moins bien Unicode que Firefox).

Essayez de trouver la police Arial Unicode MS, à tout hasard, et de l'installer. En dernier recours y'a la police Code2000 (ainsi que Code2001 et Code2002), et si là ça marche toujours pas...bah comme pour moi, vous l'avez dans le cul. (Et essayez d'imaginer la tronche d'un mec qui découvre qu'il a fait un script qui marche chez la plupart des gens, sauf sur son PC principal. x_x)

(Et sur ce je vais dormir, ne vous étonnez pas de l'absence soudaine de réponse. :3)